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  2. General Troubleshooting Guide
  3. QuickBooks Desktop Error Messages

Error 3140: The specified name is either invalid or of the wrong type

Error 3140 : While trying to Add a(n) SalesOrder with key value of 28672, QuickBooks responded There is an invalid reference to QuickBooks Customer "..... QuickBooks error message: The specified name is either invalid or of the wrong Type

Cause

QuickBooks customers, vendors, and employees exist in the same database table. When you look at vendors, you're looking at a filtered list of records where the customer type is vendor. Customers can have a type of other. Our system cannot locate customers if their type is other.

Solution

The customer type in QuickBooks must be changed. Here are the steps:

  1. In QuickBooks' top menu, click lists > other names list.
  2. Locate the customer record.
  3. Double click the row.
  4. Click the change type button:
  5. Select customer: 
  6. When promoted that the change cannot be undone, click OK.

Vendor or Employee

In QuickBooks, it is not possible to have a customer who is likewise an employee and a vendor. This happens when you buy something from a customer who bought something from you. To check if you have a vendor with the same name, follow these steps:

  1. In QuickBooks, go to vendor > vendor center.
  2. From the drop down, choose all vendors.
  3. Search for a vendor.
  4. If you find a match, rename the vendor: 

For employees the steps are the same. This error happens when you place test orders using an employee of your company.

Can I use the rules engine to change the company name?

You could say if the company was Windsor, then map the sale to Windsor orders. Here are the steps:

  1. Go to the Connex rules engine.
  2. Click action and add new rule.
  3. As the action, choose replace billing company name.
  4. As the comparison, choose matches.
  5. Enter a map from and a map to value.

Can I sync the order under another customer name?

Yes, it is possible to sync the order under a customer called web store:

  1. Login to Connex.
  2. Click manage.
  3. Expand the first area.
  4. Enter the order number into the order number list field.
  5. Expand customer.
  6. Choose single name.
  7. Click save.
  8. Run the web connector.
  9. Return to Connex and change the customer setting.
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