Items are missing and Connex failed to create them
Problem
Connex fails to sync orders to QuickBooks.
Description
When attempting to sync an order or transaction to QuickBooks, the following error message is returned to the Connex Transaction Log:
Error 3140 : While trying to Add a(n) Invoice with order number of ..., QB responded There is an invalid reference to QuickBooks Item "..." in the Invoice line. QuickBooks error message: Invalid argument. The specified record does not exist...
This means a item is missing from QuickBooks. Go to lists > item list. Connex makes items that are missing from QuickBooks.
Causes
Here are the causes:
- You deleted accounts in your QuickBooks chart of accounts in QuickBooks that Connex uses to make missing items.
- The item exists in QuickBooks, but it is marked inactive. Our tool cannot match inactive items in QuickBooks.
- The item exists on both sides, but there was a typo / inconsistency between the two
Solutions
Create the missing items in QuickBooks
In QuickBooks, go to lists > item list. Make the missing items.
Remove colons from your SKUs
Connex assumes that the item exists, if it has a colon. If it is missing, then you must create it. For more info, read this guide.
Instruct Connex to make no new items
You can map new items to existing ones. If Connex makes products, it usually means you have a mismatch.
Check if accounts exist in QuickBooks
Here are the steps:
- Login to Connex.
- Select settings.
- Click finance settings:
- Verify that these accounts exist in QuickBooks. If not, choose different ones. If the account is missing from the drop downs, refresh the list.
Check if the item is inactive
Here are the steps:
- In QuickBooks, go to lists > item list.
- On the bottom, click inactive.
- Ensure there is no X next to the item:
- If you see an X, edit the item. Uncheck the inactive field.