- General Troubleshooting Guide
- Web Connector Troubleshooting
-
Connex for QuickBooks User Guide
- Getting Started with Connex for QuickBooks
- Remote Desktop (RDP)
- Customers Matching
- Inventory Site
- Inventory Sync
- Multicurrency
- Orders
- Price Levels
- Products
- Refunds
- Sales Tax
- Sales Orders
- Unit of Measure
- Web Connector
- Getting Started with Rules
- Rules Engine Common Rules
- FAQ
- Deposit Match
- Cost of Goods Sold
- Troubleshooting
- Custom Store
-
Connex Ecommerce Analytics
-
Frequently Asked Questions
-
General Troubleshooting Guide
- Deposit Match Troubleshooting
- QuickBooks Desktop Error Messages
- Inventory Troubleshooting
- Incorrect Orders Troubleshooting
- Sales Tax Troubleshooting
- Web Connector Troubleshooting
- QuickBooks Online Error Messages
- Match Deposit Tool Troubleshooting
- Product Matching Troubleshooting
- Customer Matching Troubleshooting
- Rules Engine
- Orders from QuickBooks
- Payments Troubleshooting
- Company File
-
Connex for QuickBooks Integrations Guide
-
Rules Engine Guide
Waiting... Another Service is Updating
QuickBooks Web Connector Error: Waiting... Another service is updating
Description
The QuickBooks Web Connector is either freezing or failing to update, displaying the following message:
"Waiting... Another service is updating."
Cause
This Web Connector issue is caused by the "Auto-Run" value being set too low (i.e. 15 minutes or less). Therefore, the Web Connector is not having enough time to finish the previous task before starting the next sync.
Solution
On your computer, launch the Task Manager. Right-click on the Web Connector and click to end the task. Next, re-launch the Web Connector and let it run.
Does the issue persist?
If the issue persists, in your Web Connector, either turn the Auto-Run off, or set it for a larger value. We recommend setting the Auto-Run to 30 minutes or more.